Saturday, August 20, 2011

LibreOffice PPC Needs Beta Testers Like Mars Needs Women

I updated LibreOffice to 3.4.2 now that it's a final release and found a new feature that wasn't in the "What's New" docs. When using Writer, the font rendering of certain fixed-width fonts is a little... off. See if you can spot it. (UPDATE: This bug is fixed in LibreOffice 4.0.4)

Notice how lower case i's after lower case f's are scrunched together? The font above is Courier, but I also found the glitch on American Typewriter and Monaco, although not in other fixed-width fonts like Andale Mono and Courier New. Here's how the same sentence looked in 3.3 (and also in OpenOffice's current release):

That's how a monospace font is supposed to look, so something got screwed up in the update. Also, look what happens in the updated version when I open the sentence from a plain text document saved in TextEdit in Mac OS Roman format:

And then from a TextEdit file saved in .rtf format:

The special characters translate fine from a text document saved in UTF format, and also if it's saved in .doc format. The .rtf issue was not present in the older version, but I believe the Mac OS Roman issue was.

So get out there and start beta testing so they can catch these things!

(Don't look at me. Why are you looking at me like that?)

Sunday, August 14, 2011

"Prepping" For the Coming Apocalypse

I came across a new social movement the other day that I'd never heard of before. It's called the "Prepper" movement, and the gist of it is they're a bunch of individuals and families who believe some kind of apocalyptic event is approaching and they're "prepping" for it by buying and stocking up on wholesale goods like flower, rice, and freeze dried foods. This sounds a lot like the survivalists from the Cold War and Y2K days, but what's new is that wholesale outlets are now catering to this new crowd and reaching out for their business. Apparently there are enough of them to make a buck off of.

Anyway, all this apocalyptic talk got me thinking, "What's gonna happen to my blog?" What if the end of the world comes and Blogger pulls a Geocities with no warning? I need to back it up. I need to back it up on a hard drive. I need to back it up on disc. Hell, I need to transcribe it on stone tablet and bury it in the sand.

It turns out backing up your blog on Blogger is a simple affair. First, you sign in and go to your Dashboard and click on Settings. Right at the top are links Import Blog, Export Blog, and Delete Blog. First, put a post-it note on your screen over Delete Blog saying "DO NOT CLICK!" Then go over to Export Blog, click on it, and on the following page click the Download Blog button. An XML file containing all your posts and comments will be downloaded to your hard drive. Also, you might want to back up your blog template, so click on the Design tab at the top of the page, then hit the Edit HTML option and at the top will be a Download Full Template link. Click on it and you'll download another XML file containing your blog template. And you're done. As for transcribing it on stone tablets, I'll keep you updated on where to find a good chisel.

There's one other thing that got me thinking. Maybe these preppers are on to something. When hyperinflation or massive solar flares bring down the world order, we'll all be reduced to caveman technologies like manual can openers, hand crank generators, and... PowerPC! Think of the power we'll wield. Soon everyone will be turning to us for guidance. And when they ask us, "How do we turn off that darn fangled Spotlight?" we will tell them. And when they say, "How do I use this cotton pickin' Youtube?" we will show them the way. But I plead with you, fellow PowerPCers, show humility. They're likely to be traumatized, refugees in the truest sense. And don't make judgy comments about their tattered clothes. We must all survive together, PowerPCers, Intel refugees, tattered clothes and dirty faces and all.

Thursday, August 11, 2011

Time to Update MacTubes Again

Youtube changed something in their url schemes, so time to update MacTubes to 3.0.8 to get it working again. Test it by doing a search of throwing muses bright yellow gun rvsaid and see possibly the most incongruent match between band and studio audience ever.

Sunday, August 7, 2011

WPA Wireless in Debian on a G3 iBook

Setting up wireless with an original Airport card is really easy with one caveat. WPA encryption doesn't work out of the box, just WEP, and everyone says using WEP is like opening your front door at night and having big search lights on your lawn inviting every robber in the greater metropolitan area to help themselves to your leftover chicken. And we don't want that.

So to get WPA access working, you need to add contrib and non-free repositories to your /etc/apt/sources.list file (just add contrib and non-free after main) and sudo aptitude update, and then:

sudo aptitude install linux-firmware-nonfree UPDATE: that's actually firmware-linux-nonfree

This installs the firmware needed to get WPA working. It also installs other bits of firmware, such as firmware for improved performance on ATI cards, so if you've already installed the package for your graphics card you don't need to install it again.

Next, you want to install wireless-tools and wicd. wicd is a very simple to use network manager that doesn't require Gnome, so you can use it in any environment. However, you can't have two network managers running at the same time, so if you already have Gnome's somewhat crappy network manager running, installing wicd will uninstall it.

Next, run wicd-client -n. This will open the graphical client. Open Preferences and type in your wireless interface (mine was eth1, but you can find out yours by running sudo iwconfig). Then close Preferences and hit the Refresh button and follow your intuition...

Okay, specifically find your network among the list and click Properties. Click "Use Encryption" and below select "WPA 1/2 (Passphrase)" and enter your router's wireless password. Then click Okay and then click Connect. You'll also want to check the "Automatically connect to this network" box if you want it to... automatically connect to the... you got it.

And as is my constant refrain, if the above didn't work I blame you. And that the response you get in the Debian forums will be slightly more professional.

UPDATE: I should also note the firmware supports only WPA, not WPA2. Also, connections will fail with AES encryption, so set your router for TKIP encryption instead.